각 라우터에 RIP 버전 2 동적경로 설정
R1~5(config)#router rip
R1~5(config-router)#version 2
R1~5(config-router)#network 10.0.0.0
R1~5(config-router)#no auto-summary
R1#sh ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
C 10.0.0.0/24 is directly connected, FastEthernet0/0
L 10.0.0.1/32 is directly connected, FastEthernet0/0
C 10.0.1.0/24 is directly connected, FastEthernet0/1
L 10.0.1.1/32 is directly connected, FastEthernet0/1
C 10.0.2.0/24 is directly connected, FastEthernet1/0
L 10.0.2.1/32 is directly connected, FastEthernet1/0
C 10.0.3.0/24 is directly connected, FastEthernet1/1
L 10.0.3.1/32 is directly connected, FastEthernet1/1
R 10.1.0.0/24 [120/1] via 10.0.0.2, 00:00:20, FastEthernet0/0
R 10.1.1.0/24 [120/2] via 10.0.0.2, 00:00:20, FastEthernet0/0
[120/2] via 10.0.3.2, 00:00:03, FastEthernet1/1
R 10.1.2.0/24 [120/2] via 10.0.3.2, 00:00:03, FastEthernet1/1
R 10.1.3.0/24 [120/1] via 10.0.3.2, 00:00:03, FastEthernet1/1
<aside> 💡 RIP 관리거리(ad) 120
홉수가 적은 R1에서 R4까지가는 홉수가적은 하단경로로 설정됨
10.1.1.0 은 경로가 2개인데 홉수가 2개로 동일해서이다.
</aside>
각 라우터에 OSPF 동적경로 설정
R1(config)#router ospf 1
R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
R1(config)#do sh ip route
10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
C 10.0.0.0/24 is directly connected, FastEthernet0/0
L 10.0.0.1/32 is directly connected, FastEthernet0/0
C 10.0.1.0/24 is directly connected, FastEthernet0/1
L 10.0.1.1/32 is directly connected, FastEthernet0/1
C 10.0.2.0/24 is directly connected, FastEthernet1/0
L 10.0.2.1/32 is directly connected, FastEthernet1/0
C 10.0.3.0/24 is directly connected, FastEthernet1/1
L 10.0.3.1/32 is directly connected, FastEthernet1/1
O 10.1.0.0/24 [110/2] via 10.0.0.2, 00:00:36, FastEthernet0/0
O 10.1.1.0/24 [110/3] via 10.0.0.2, 00:00:26, FastEthernet0/0
O 10.1.2.0/24 [110/21] via 10.0.3.2, 00:00:06, FastEthernet1/1
O 10.1.3.0/24 [110/20] via 10.0.3.2, 00:00:06, FastEthernet1/1
--------------------------------------
대역포 기본값은 100Mps // 하단경로 R5의 인터페이스 대역폭은 아래와같이 10Mps이다
R5#show run | section interface
interface FastEthernet0/0
bandwidth 10000
ip address 10.1.3.2 255.255.255.0
duplex auto
speed auto
interface FastEthernet0/1
bandwidth 10000
ip address 10.0.3.2 255.255.255.0
duplex auto
speed auto
<aside> 💡 OSPF 관리거리(ad) 110
관리거리가 낮은 110으로 모든경로가 OSPF로 대체된다.
RIP 와 다르게 10.1.1.0 경로는 하나인데 OSPF는 인터페이스의 대역폭을
우선하기때문에 상단경로로 경로설정됨.
</aside>
인터페이스 disable 상황
만약 상단 경로인 R2의 f0/0 경로가 비활성화 되면 아래와같아진다
R2(config)#int f0/0
R2(config-if)#shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
02:41:32: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.3.1 on FastEthernet0/0 from FULL to DOWN,
Neighbor Down: Interface down or detached
-----------------------------------
R1#sh ip route
10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
C 10.0.1.0/24 is directly connected, FastEthernet0/1
L 10.0.1.1/32 is directly connected, FastEthernet0/1
C 10.0.2.0/24 is directly connected, FastEthernet1/0
L 10.0.2.1/32 is directly connected, FastEthernet1/0
C 10.0.3.0/24 is directly connected, FastEthernet1/1
L 10.0.3.1/32 is directly connected, FastEthernet1/1
O 10.1.0.0/24 [110/22] via 10.0.3.2, 00:00:56, FastEthernet1/1
O 10.1.1.0/24 [110/21] via 10.0.3.2, 00:00:56, FastEthernet1/1
O 10.1.2.0/24 [110/21] via 10.0.3.2, 00:00:56, FastEthernet1/1
O 10.1.3.0/24 [110/20] via 10.0.3.2, 00:00:56, FastEthernet1/1
<aside> 💡 상단경로로 잡혀있던 경로가 하단경로로 변경되고 metric값이 높아졋다 (21로) 경로 선호도는 메트릭값이 낮은걸 선호한다.
</aside>
링크상태와 거리백터
R1#show ip ospf database
OSPF Router with ID (10.0.3.1) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
10.1.3.2 10.1.3.2 1487 0x80000004 0x006e65 2
10.1.1.2 10.1.1.2 1472 0x80000004 0x00529f 2
203.0.113.1 203.0.113.1 1472 0x80000005 0x00df85 3
10.0.3.1 10.0.3.1 415 0x80000007 0x00557f 3
10.1.0.2 10.1.0.2 415 0x80000005 0x00cb51 1
Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.0.3.1 10.0.3.1 1528 0x80000001 0x00c2e8
10.1.0.2 10.1.0.2 1511 0x80000002 0x00b4fb
10.1.3.1 203.0.113.1 1487 0x80000001 0x000942
10.1.1.1 203.0.113.1 1472 0x80000002 0x0070e9
<aside> 💡 거리벡터라우팅 종류인 RIP는 직접연결된 이웃과 해당이웃이 광고한 네트워크 목록만 가지고있지만
링크상태인 OSPF는 해당영역에있는 모든 링크상태의 라우터들의 정보를 다가지고 있는걸 볼수있다.
</aside>
각 라우터에 EIGRP 동적경로 설정
R1(config)#no router ospf 1
R1(config)#router eigrp 100
R1(config-router)#no auto-summary
R1(config-router)#network 10.0.0.0 0.255.255.255
10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
C 10.0.0.0/24 is directly connected, FastEthernet0/0
L 10.0.0.1/32 is directly connected, FastEthernet0/0
C 10.0.1.0/24 is directly connected, FastEthernet0/1
L 10.0.1.1/32 is directly connected, FastEthernet0/1
C 10.0.2.0/24 is directly connected, FastEthernet1/0
L 10.0.2.1/32 is directly connected, FastEthernet1/0
C 10.0.3.0/24 is directly connected, FastEthernet1/1
L 10.0.3.1/32 is directly connected, FastEthernet1/1
D 10.1.0.0/24 [90/30720] via 10.0.0.2, 00:02:25, FastEthernet0/0
D 10.1.1.0/24 [90/33280] via 10.0.0.2, 00:02:25, FastEthernet0/0
D 10.1.2.0/24 [90/35840] via 10.0.0.2, 00:01:12, FastEthernet0/0
D 10.1.3.0/24 [90/261120] via 10.0.3.2, 00:01:31, FastEthernet1/1
<aside> 💡 EIGRP 관리거리(ad) 90
메트릭값은 30720,33280, .. , ..
EIGRP는 대역폭과 지연을 고려한 복합 메트릭 사용한다
</aside>
루프백 인터페이스
루프백 인터페이스는 논리적 인터페이스이다.
루프백을 통해 물리적 인터페이스에 묶이지 않은 라우터나 3계층 스위치에 ip주소를 할당이 가능하다.
물리적으로 경함이 생길 요소가 없기때문에 루프백 인터페이스는 항상 유지가된다.
루프백은 OSPF에서 라우터를 식별할 때에도 사용이되는데 라우터의 ID로쓰이기 때문이다.
위와 같은 토폴리지에서 R1,R2,R3,R4 는 조직 내부에있고 제휴사인 R6라우터가 있다고 해보자
내부에서는 제휴사인 R6에게 내부 네트워킹에 관한 정보를 보내면 안되는 상황일때
루프백인터페이스를 수동인터페이스로 잡아주는면 해결이된다.
이는 물리적인 링크가 아니기때문에 R6에서 인접성을 형상하지않고 정보가 넘어오는일도없어진다.
<aside> 💡 내부게이트웨이 라우팅 프로토콜인 RIP,EIGRP,OSPF는 라우터는 직접 연결된 링크 상의 다른 장치들을 탐색하게 되면 서로 Hello패킷을 전송하고 수신대기를하며 대등접속을 하게되고 인접성 형성해 서로 라우팅 업데이를 교환한다.
</aside>
사용
루프백 인터페이스 구성
루르팩인터페이스 설정
R1 - interface loopback 0
R1 - ip address 192.168.1.1 255.255.255.255
동적경로와 수동인터페이스 설정
R1 -R5 router rip
R1 -R5 version 2
R1 -R5 no auto-summary
R1 - passive-interface loop0
R1 - passive-interface f2/0
R1 -R5 network 192.168.1.1
R1 -R5 network 10.0.0.0
위와같이 설정하고 경로를 확인하면
맨좌측에있는 R4에서 R1뒤에있는 2개의 인터페이스로가는 경로가 설정이되고
R6 라우터에서 경로를 확인해보면 다른 인터페이스로가는 경로를 전혀 설정이되지않는다.
'Network' 카테고리의 다른 글
실장비 네트워크 구축 (1) | 2023.10.04 |
---|---|
23. RIP EIGRP (1) | 2023.10.04 |
21. 동적 경로 이론 (0) | 2023.10.04 |
20. 정적 경로 (0) | 2023.07.13 |
19. 라우터 로컬 경로 (0) | 2023.07.13 |